Fórum pro uživatele kancelářského balíku OpenOffice | LibreOffice
 

#1 Re: Chyba v programu » Vkládání obrázků- LO » 12. 12. 2014 18:09:04

Vyzkouším příště při převodu internet -> swriter. Ve druhém případě- tvorba html pomocí LO ale možnost něco označit ve smyslu ponechat spojení nevidím. Protože html dokument posílám dál, vždy ručně musím vymazat úsek "data" a nahradit ho odkazem. Nešlo by to lépe?

#2 Re: Chyba v programu » Legenda grafu-VYŘEŠENO » 10. 12. 2014 15:50:30

Přidávám informaci- jde o poslední stabilní versi LO

#3 Chyba v programu » Vkládání obrázků- LO » 10. 12. 2014 15:47:48

Cmelak
Odpovědí: 3

Je to věc pro vývojáře, ale přimlouval bych se, aby bylo možno volit, jestli chci obrázky vložit odkazem nebo kódem
Když chci uschovat něco z internetu do odt souboru, dělám to většinou proto, že třeba za měsíc už stránka nemusí existovat. Logické je začlenit obrázek do kódu. Když vytvářím html dokument, naopak se může stát, že budu i obrázek vylepšovat nebo měnit text, lepší je nechat obrázek jako odkaz.

#4 Chyba v programu » Legenda grafu » 10. 12. 2014 15:40:04

Cmelak
Odpovědí: 1

Chtěl jsem vykreslit graf, kde bylo 7 průběhů typu veličina- její aproximace. Pro přehlednost jsem chtěl, aby veličina i aproximace se zobrazily stejnou barvou a lišily se charakterem. Když jsem upravoval legendu, chtěl jsem původně použít vykreslení plnou čarou- čarou přerušovanou. Jakmile jsem ale zvolil jinou čáru než plnou, zmizely mi v legendě všechny "aproximace" (v grafu zůstaly). Nakonec jsem musel použít pro odlišení jen různou tloušťku čáry. Kde je chyba?

#5 Chyba v programu » Legenda grafu-VYŘEŠENO » 10. 12. 2014 15:38:40

Cmelak
Odpovědí: 2

Chtěljsem vykreslit graf, kde bylo 7 průběhů typu veličina- její aproximace. Pro přehlednost jsem chtěl, aby veličina i aproximace se zobrazily stejnou barvou a lišily se charakterem. Když jsem upravoval legendu, chtěl jsem původně použít vykreslení plnou čarou- čarou přerušovanou. Jakmile jsem ale zvolil jinou čáru než plnou, zmizely mi v legendě všechny "aproximace" (v grafu zůstaly). Nakonec jsem musel použít pro odlišení jen různou tloušťku čáry. Kde je chyba?

Nalezeno- jakmile v legendě zvolíme přerušovanou čáru, obrázek čáry se prodlouží. Protože legenda byla ohraničená, text a další zmizelo za hranicí. Stačí zvětšit okno legendy- nebo ponechat tenčí čáru...

#6 Re: Chyba v programu » Přepis jmen obrázků » 10. 2. 2014 20:52:01

Mírná oprava posledního příspěvku: jméno obrázku v html dokumrntu nabobtnalo na víc jak 10 000 znaků. Tentokráte náhodou jsem v tom "gif" našel.

#7 Chyba v programu » Přepis jmen obrázků » 10. 2. 2014 20:35:04

Cmelak
Odpovědí: 2

Když vytvářím html dokument pomocí LO, někdy se obrázky přejmenovaly, někdy ne. S versí 4.2 se mi stává podivná věc- vlastní obrázek se nepřejmenuje, ale při dalších otvíráních se doba otevření značně prodlužuje. Když html dokument otevřu Contextem, vidím že jméno obrázku úplně zmizelo včetně extense (gif) a místo toho se objeví strašně dlouhá řádka- možná 1000 znaků. Pomoc je sice snadná, řádku nahradím zpět jménem a je to. Ovšem mnohem pohodlnější je použít AOo.

Samozřejmě problém ukládání, jak jsem zde četl, mám také. Pokud se mi podaří soubor přes stálou "práci" uložit, většinou problém zmizí a víc se neopakuje. Zkusím některou radu.

#8 Chyba v programu » Java nebo msvcr100? » 21. 11. 2012 17:59:28

Cmelak
Odpovědí: 0

Už jsem na toto téma psal, problém vyřešil... ale po upgrade asi Visty se vše vrátilo- nešlo nastartovat ani OOo, ani LO. Opět vyřešeno záměnou msvcr100.dll verse 10.00.40219.325 za 10.00.20327.1 (v c:\windows\system32). Jenže jak dlouho to bude fungovat? Kdy nastane situace, že záměnou začne zlobit něco jiného? V počítači mám ještě tento soubor v javě, GoogleEarth, Firefoxu a Thunderbirdu, všude zde ale verse 10.00.30319.1 Když do system32 jsem přesunul tuto versi, tak se objeví chyba "špatná verse javy" a teprve po pěti "prokliknutích se to přece jen nakonec spustilo.
Co s tím? Možnosti jsou dvě: buď oba programy- OOo i LO "naučit" počítat s novými verzemi- momentálně s  10.00.40219.325- nebo alespoň zajistit volámí msvcr100 pouze relativní adresou. Protože c:\windows\system32 je v path, normálně by se to obracelo sem, tedy na špatný soubor, ale vyhovující verse by mohla být rovnou v adresáři c:\Program Files\LibreOffice 3.6\program\ respektivě c:\Program Files\OpenOffice.org 3\program\. Spuštěný program by si modul vzal ze svého adresáře a bylo by po problémech navždy. Tím spíše, že jde řádově o 700kB, to je proti cca 200MB směšně málo.V současné době tato možnost ale nefunguje, zkoušel jsem to. Skutečně misím sáhnout do c:\windows\system32.

Jinak mimochodem- když jsem hledal verse msvcr100 na googlu, zjistil jsem, že tento jinak neškodný soubor dělá těžkou hlavu na mnoha dalších místech. O to lepší důvod vložit správnou versi přímo do kancelářského balíku.

#9 Re: Chyba v programu » Java JRE » 31. 10. 2012 21:17:20

Možná, že by pomohla výměna msvrc100.dll- viz můj problém. Balíky také začaly zlobit po aktualizaci Javy. Výměna msvcr za starší, přitom novější verzi pomohla. Možná. Na 100% to tvrdit nemohu, pokud jde o systém a windows zvláště, jsem jen amatér.

#10 Re: Chyba v programu » OpenOffice ani LibreOffice nestartují » 31. 10. 2012 21:10:17

Po více jak měsíci mohu případ (snad) uzavřít. Podíval jsem se na oficiální stránky k msvcr100 a našel jsem tam 4 verze. Dvě nefungovaly vůbec. Verse 10.00.30319.1 fungovala podivně- hlásila chybu v Javě, po mnoha odkliknutích nakonec se podařilo LO i OO nastartovat. Tuto versi uvádím proto, že v diskusním fóru se o chybné Javě mluví také často. Nejlépe jsem dopadl s verzí 10.00.20327.1- oba balíky začaly šlapat bez problému. Je zajímavé, že jde podle čísla o starší verzi msvcr, ale podle data vydání je mladší než ta poslední (16.11.2011 oproti 4.6.2011).

#11 Re: Chyba v programu » OpenOffice ani LibreOffice nestartují » 28. 9. 2012 08:40:01

Nainstalováno  MS Visual C++ 2010 Runtime SP1- restart počítače- nová instalace L_O i O_O- nepomohlo. Zatím naštěstí Potrable verse funguje dál.

#12 Chyba v programu » OpenOffice ani LibreOffice nestartují » 26. 9. 2012 19:54:45

Cmelak
Odpovědí: 3

Od jistého data nemám funkční ani jeden z obou kancelářských balíků, funguje jen LibreOffice Portable. Nejprve se hlásila u OOo chyba v Javě, nyní se standardně hlásí chyba chybný modul MSVCR100.dll. U LO se program poprvé spustil, pak už jen hlásil stejnou chybu. Zdá se, že se chyby objevily po update Javy. Sice Portable verse to zachraňuje, ale jednak je pomalá, navíc nelze do ni nainstalovat některé doplňky. Uvádim typický výpis:


Název události problému:    BEX
  Název aplikace:    soffice.bin
  Verze aplikace:    3.6.1.2
  Časové razítko aplikace:    50340515
  Název chybného modulu:    MSVCR100.dll
  Verze chybného modulu:    10.0.40219.1
  Časové razítko chybného modulu:    4d5f0c22
  Posun výjimky:    0008af3e
  Kód výjimky:    c0000417
  Data výjimky:    00000000
  Verze operačního systému:    6.0.6002.2.2.0.768.3
  ID národního prostředí:    1029
  Další informace 1:    73db
  Další informace 2:    8b55d129bafc6f154035c86abc18c809
  Další informace 3:    adf2
  Další informace 4:    87f9f8bc4da0a3bd6bb1a1dd15a6e360

Zápatí

Používáme FluxBB