Fórum pro uživatele kancelářského balíku OpenOffice | LibreOffice
 

#1 14. 12. 2021 15:38:23

jirasek1944
Člen
Registrace: 2. 12. 2012
Příspěvků: 49

V buňce se zobrazuje #VALUE! Vyřešeno

Z vyúččtování od České spořitelny jsem nějméně 2 roky do tabulky v Libreofficem Calc kopíroval údaj o částce. Nyní však dochází k tomu, že se v buňce v níž má být okopírované číslo přičteno nebo odečteno namísto toho zobrazí výše v předmětu uvedené, tj. #VALUE!. Vzorec tam mám určitě zadám správně, protože pokud napíšu číslo ručně je to sečteno správně a zobrazí se výsledek.Čím by to mohlo být prosím ?

Nemůže mnou zmíněný problém souviset s tím, že jsem aktualizoval Windows 10 a přešlo mi to na Windows 11? Mnou zmíněné zobrazení v buňce v níž má být výsledek součtu, ale místo toho se tam zobrazí #VALUE! je právě tak od toho dne, co jsem původní Windows 10 aktualizoval.

Editoval jirasek1944 (22. 1. 2022 18:45:41)

Offline

#2 14. 12. 2021 16:20:05

ludviktrnka
Člen
Registrace: 9. 7. 2009
Příspěvků: 678

Re: V buňce se zobrazuje #VALUE! Vyřešeno

Pravděpodobně je v buňce číslo jako text. Projevuje se to apostrofem na začátku čísla, je to vidět v  zadávacím řádku nebo po dvojkliku na buňku. Léčba je pomocným sloupcem =value(A1) pak případně zkopírovat a vložit na původní místo (pouze čísla).


LibreOffice 6.2.

Offline

#3 14. 12. 2021 17:23:57

jirasek1944
Člen
Registrace: 2. 12. 2012
Příspěvků: 49

Re: V buňce se zobrazuje #VALUE! Vyřešeno

jirasek1944 napsal(a)

Z vyúččtování od České spořitelny jsem nějméně 2 roky do tabulky v Libreofficem Calc kopíroval údaj o částce. Nyní však dochází k tomu, že se v buňce v níž má být okopírované číslo přičteno nebo odečteno namísto toho zobrazí výše v předmětu uvedené, tj. #VALUE!. Vzorec tam mám určitě zadám správně, protože pokud napíšu číslo ručně je to sečteno správně a zobrazí se výsledek.Čím by to mohlo být prosím ?

Jwe to nějaké divné, protože když okopíruji částku uvedenou ve výpisu z ČS, následně kliknu pravým tl. na buňku do níž chci číslo vložit, v nabídce kliknu levým tl. na Vložit nebo vložit jinak a pak neformátovaný text - okopíruje se jak je zobrazeno ve výpisu z ČS. Kliknu-li však na Vložit jinak a pak na číslo, text nebo vzorec neokopíruje se nic. Pokud číslo z ČS vložím do jiné buňky a z ní se snažím vložit do správné buňky jako číslo - rovněž se neokopíruje nic. Mně to případá, že oni tam snad mají to číslo dané jako text - což zase ale není možné, protože by jim částky matematicky nefungovaly.
Já se pochopitelně bez toho obejdu, ale budu tam muset hodnotu čísla vkládat ručně namísto toho, když jsem ji tam mohl okopírovat.

Offline

#4 17. 12. 2021 01:12:18

lp.
Člen
Registrace: 24. 9. 2009
Příspěvků: 830

Re: V buňce se zobrazuje #VALUE! Vyřešeno

Nenapsal jste odkud kopírujete. V některých výpisech (výpisy ČS neznám) bývají čísla proložena neviditelnými unicode znaky, někdy s nulovou délkou. viz např. wikipedie. Zkuste je najít a pak mazat.

Najít - může pomoci např. funkce mid, vyberte jednotlivé znaky podle pořadí třeba do sousedních buněk. Pokud bude některá buňka zdánlivě prázdná, můžete zviditelnit kód znaku v "prázdné" buňce - funkce asc, ...

Offline

#5 17. 12. 2021 14:55:11

kamlan
Člen
Registrace: 15. 9. 2016
Příspěvků: 368

Re: V buňce se zobrazuje #VALUE! Vyřešeno

lp. napsal(a)

V některých výpisech (výpisy ČS neznám) bývají čísla proložena neviditelnými unicode znaky, někdy s nulovou délkou.

@jirasek1944: V Calcu by šlo použít i fci LEN vracející délku řetězce. Pokud by vám LEN např. na dvouciferné číslo vypsalo délku 3 nebo 4, tak je jasné že to nejsou jen dvě číslice ale že tam je něco navíc.


Doplněk TypoJTB umí zobrazit kódy znaků ve Writeru. Mělo by stačit to "číslo" zkopírovat do prázdného dokumentu, dát Ctrl+A aby to bylo označené vše a Nástroje/ Přídavky/ TypoJTB/ Informace o kódech znaků. Vypíše to Ascii hodnoty jednotlivých znaků ve výběru -> a číslice 0-9 mají hodnoty Dec: 48-57. Když tam bude nějaký neviditelný znak, tak bude mít hodnotu nejspíš kolem Dec: 8200.

d3RI.jpg

Editoval kamlan (17. 12. 2021 14:55:48)

Offline

Zápatí