Fórum pro uživatele kancelářského balíku OpenOffice | LibreOffice
 

#1 6. 3. 2015 09:15:44

sipek
Člen
Registrace: 4. 9. 2013
Příspěvků: 5

Impress - Vyřešeno

Dobrý den, prosím o radu, narazil jsem na následující problémy (používám Ooo 4.1.1 a win 8.1 pro x64):
1. Při psaní vzorců jsem v předchozích verzích se integrály zobrazovaly jinak a lépe (Ux226B) a v současné verzi při volání příkazu int se objeví znak integrálu jako by byl ve fontu Ariel. Vše co jsem dříve napsal se změnilo. Je možné to nějakým způsobem nastavit zpět?
2. Pokud vytvořím prezentaci a dám tisk podkladů, tak ve starší verzi je nastaveno 4 snímky na stránku, stránka je orientována na šířku. V nové verzi se mi objeví 6 snímků na stránku a stránka je orientována na výšku. Pokud změním počet snímků, na 4 stránka zůstane orientována na výšku. Změním-li orientaci na šířku, obrázky zůstano ve stejném rozměru, nezvětší se. Je možné s tím něco udělat.
3. Pokud kopíruji text vytvořený ve Writeru do Impressu ne převedou se správně české znaky „ě,š,č,ř,ů".
Za rady předem děkuji.

Editoval sipek (18. 8. 2015 08:05:23)

Offline

#2 6. 3. 2015 09:53:43

neutr
Člen
Registrace: 8. 3. 2007
Příspěvků: 2,697

Re: Impress - Vyřešeno

1. Písmo se nastavuje pro vzorce stejně jak pro AOO, tak pro LO. Když otevřete editor vzorců a zvolíte nabídku FORMÁT tak hned první položka je písmo. Dá se navolit pímo pro text samostatně a samostatně pro vzorec (indexy ap). Já mám v AOO4.1.1. nasteveno TimesNewRoman pro všechno.
     Editor vzorců funguje stejně ve Writer, Impress i Calc. Takže stačí zavolat vložit vzorec, nebo kliknout na existující vzorec. S nastavením písma souvisí formátování. Takže byste měl upravit styl. To už může být trošku oříšek. Když ale napíšete vzorec tak aby vyhovoval, stačí ho přeformátovat. problém je v tom, že se to zobrazí každému jinak podle nastavení. Takže zejména v Impressu (pro Impress) byste měl udělat ze vzorce obrázek a nic nepokazíte.



     Ta druhá věc je dána asi dvěma nastaveními. Jednak těch vlastních obrázků, tak listu na který se vkládají. To byste asi měl lépe popsat.


     Ten třetí problém je v exportním (importním) filtru. Teoreticky by měla být nastavena znaková sada pro celé AOO (LO) shodně. Bohu žel není. Zjistil jsem to nedavno v souvislosti na export z Base. Implicitně je nastavena zřejmě sada UTF 16. Jednotlivé dokumenty mají implicitně ASCII 8 bit. Problém je v tom, že znaky, které nejsou v americkí verzi mají v UTF za znakem 127 jiné číslo. Když se to překopírzje, dostanou číslo ASCII 7 bit + jiná znaková sada.
     Tento problém zatím obcházíme nahrazováním (najít a nahradit), ale mělo by být jiné systémové (a tedy lepší) řešení. Nejspíš půjde o to najít vhodnou znakovu sadu.


Pokud je Váš problém vyřešen, označte prosím svůj příspěvek za "VYŘEŠENÝ"
Zlepšíte tak orientaci na fóru při vyhledávání řešení problémů
JAK OZNAČIT TÉMA ZA VYŘEŠENÉ

Offline

#3 6. 3. 2015 10:58:44

sipek
Člen
Registrace: 4. 9. 2013
Příspěvků: 5

Re: Impress - Vyřešeno

Dobrý den, děkuji za rychlou odpověď, ale bohužel to nefunguje. V položce formát je písmo nastaveno tak jak ho požaduji "Times New Roman" Symboly se tak zobrazují, ale znak pro integrál nikoliv. Napíši-li vew vzorci "int" je to ve formátu arial. Vyberu-li symbol U 222B jedná se znak integrálu v "Times". Kolega to zkoušel otevřít v Libre Office se starším OS a integrá se zobtazuje v "Time". Osobně mám dojem, že se jedná o problém mezi Ooo 4.1.1 a Win 8.1, ale nevím

V Impressu jsem tvořil řadu prezentací. Vytvořil jsem si jednu a pak ty další kopíroval a měnil náplň. První prezentace jsem tvořil v Ooo 1. (V Oo již pracuji cca 12 let)  Poslední dobou mi prezentace padali (celý Ooo) ale ne při prezentaci, ale při akcích jako přímý export do pdf, nebo přesun snímků, tisk apod. Problém jsem konzultoval s našimi informatiky a jejich návrh byl vytvořit novou prezentaci v Ooo4.1.1, protože se mohou hromadit chyby při změnách verzí. Takže v současné době mám starší prezente (vytvořeno ve starších verzích Ooo), které při tisku podkladů se připraví automaticky 4 snímky na list na šířku. Nová prezentace se při stejné akci objeví 6 snímků na výšku. Pokud vyberu 4 snímky, zobrazí se 4 snímky, ale stránka zůstává na výšku. Otočím-li ji v nastavení tiskárny, otočí se, ale snímky zůstávají ve stejné velikosti. Pokud bych tisknul prezentaci 1 snímek na list, orientace i rozměr jsou v pořádku.

Třetí problém budu řešit také tak jak jsem ho řešil doposud, najít-nahradit.
Předem děkuji

Offline

Zápatí