Fórum pro uživatele kancelářského balíku OpenOffice | LibreOffice
 

#1 10. 8. 2014 04:24:32

neutr
Člen
Registrace: 8. 3. 2007
Příspěvků: 2,953

Chyba podmíněného formátu v LO 4.3.0.4

Podmíněné formátování v LO 4.3.0.4 při některých manipulacích způsobuje pád a nepamatuje si kopírovaný podmíněný formát.


     Bezpečně lze nastavit podmíněný formát jen přímou volbou pro buňku. FORMÁT > PODMÍNĚNÝ FORMÁT. Když tuto originálně formátovanou buňku (podmínka se vzorcem) vykopíruji do úseku tak tam sice ten podmíněný formát je, ale po uložení a zavření sešitu se ztratí.
     Nepomáhá ani kopírování po jednotlivých buňkách. Lze podmíněný formát sice 'udržet', ale za cenu otevření podmíněného formátování a přepsání úseku. Po zkopírování je tam správně vzorec, ale ne platnost pro úsek. Takže když se přepíše platnost úseku, podmíněný formát se udrží.
     Jenomže když tyto manipulace zkusím udělat na vybraném úseku pomocí 'Spravovat' tak LO spadne. Přepisovat chybnou platnost úseku lze jen zavoláním FORMÁT > PODMÍNĚNÝ FORMÁT, kde se po zavolání objeví hlášení, že buňka už formát má - je nutno upravit. Následně lze platnost úspěšně přepsat a uložit. Je to prakticky shodný postup s prvním vytvořením podmínky. Tento má výhodu jen v tom, že vykopírovaný vzorec podmínky je správně. Takže se přepíše jen platnost, což je snadnější, nežli přepisovat vzorec podmínky.


     Abych se vyhnul manuálnímu přepisování, otevřu v AOO, vykopíruji podmíněný formát a je to v pořádku. Bohu žel AOO neumí tolik podmínek jako LO, takže když existují více nežli 3 podmínky ani podobná improvizace nepomůže.


Pokud je Váš problém vyřešen, označte prosím svůj příspěvek za "VYŘEŠENÝ"
Zlepšíte tak orientaci na fóru při vyhledávání řešení problémů
JAK OZNAČIT TÉMA ZA VYŘEŠENÉ

Offline

#2 10. 8. 2014 23:23:14

PetrValach
Člen
Registrace: 24. 5. 2007
Příspěvků: 557

Re: Chyba podmíněného formátu v LO 4.3.0.4

To mi hlava nebere... udělal jste podmíněné formátování a buňky takto formátované jste rozkopíroval? A ono to po uložení nefunguje?

Mně jo...


Pokud je Váš problém vyřešen, označte prosím svůj příspěvek za "VYŘEŠENÝ"
Zlepšíte tak orientaci na fóru při vyhledávání řešení problémů
JAK OZNAČIT TÉMA ZA VYŘEŠENÉ

Offline

#3 11. 8. 2014 07:23:06

neutr
Člen
Registrace: 8. 3. 2007
Příspěvků: 2,953

Re: Chyba podmíněného formátu v LO 4.3.0.4

Ano přesně tak. Možná jde o určitou verzi - máte LO 4.3.0.4? Nebo také OS - Já jsem to zjistil na W-XP. Na Ubuntu mám starší verzi LO, tak až to přeinstaluji napíšu jestli to tam dělá také.
     Je otázkou zda jste po vykopírování uložil sešit a zavřel. Těsně po vykopírování se to tváří jako že to tam je. Po znovuotevření je to pryč i když to bylo správně uložené.

Editoval neutr (11. 8. 2014 07:27:20)


Pokud je Váš problém vyřešen, označte prosím svůj příspěvek za "VYŘEŠENÝ"
Zlepšíte tak orientaci na fóru při vyhledávání řešení problémů
JAK OZNAČIT TÉMA ZA VYŘEŠENÉ

Offline

Zápatí