Fórum pro uživatele kancelářského balíku OpenOffice | LibreOffice
 

#1 25. 10. 2013 10:32:36

ostraticky
Člen
Registrace: 25. 10. 2013
Příspěvků: 1

Chybná práce Calc se schránkou systému

Čím to že pracuji-li se dvěma Calc dokumenty mezi kterými potřebuji kopírovat údaje z tabulek vzniká následující chyba:

otevřu Dokument 1 - vybranou oblast zkopíruji do schránky - zavřu Dokument 1 - otevřu Dokument 2 -  vložím oblast ze schránky → oblast se vloží objekt (???)

otevřu Dokument 1 - vybranou oblast zkopíruji do schránky - otevřu Dokument 2 - vložím oblast ze schránky → oblast se vloží jako součást dokumentu (o.k.)

Oba výchozí dokumenty jsou *.odt. Jedná se o poslední verzi OpenOffice

Offline

#2 25. 10. 2013 14:00:34

Ondra.kl
Člen
Registrace: 30. 9. 2008
Příspěvků: 933

Re: Chybná práce Calc se schránkou systému

Kterou poslední verzi OpenOffice máte na mysli? OOo 3.4.1, jeho pokračovatele AOO 4.0.1 či snad LO 4.1.2?

Offline

#3 25. 10. 2013 14:47:15

neutr
Člen
Registrace: 8. 3. 2007
Příspěvků: 2,659

Re: Chybná práce Calc se schránkou systému

Existuje více druhů vkládání. Mezi dvěma Calcy existuje 7 různých způsobů vložení dat. Základní nastavení schránkou je běžně "co na srdci - to na jazyku". Když ale vkládáte z jiného dokumentu a nezadáte "jak", tak si to zvolí samo formát. Jde nejčastěji o běžný text a čísla. Ale často se vkládá také objekt. To se děje častěji mezi Writer a Calc-em.


Je pravdou, že pokud jde o Calc stejné verze AOO (LO) tak by to mělo být stejné, jako když jsou oba otevřené současně (ale i kdyby ne, tak se to za chybu pokládat asi nemůže). Když by šlo o jiné verze - novější a kopírujeme ze starší, tak se to projeví (tedy ne nutně) vložením jako objektu. To je dané tím, že když jsou oba sešity otevřeny, tak pod stejným systémem. Když ten starší ale zavřeme, tak ten "nově otevřený" to už neví a loupne tam objekt. Takže vyzkoušejte nejdříve ten původní otevřít, mírně pozměnit a uložit tak, aby měly oba Calky stejnou verzi.



Já jsem tuto vlastnost nalezl jen mezi kopírováním z LO do AOO. Tak je to celkem logické. Takže tohle se může projevit, když kopírujete ze staré verze (soubor bývá vypsán modře) do nové. Ale nejspíš je to kopírování mezi AOO a LO.


Také by mělo pomoci například to, že když se objeví místo dat "objekt s daty", tak to smažte a vyzkoušejte vložit jinak - zvolit DDE. DDE je také "odkaz" ale dá se rozpojit a pak je to jako "normální kopírování".


Takže tohle asi chyba nebude. Ale ani tak bych to za chybu nepokládal.



Pokud je to jinak, napište prosím jakou verzi AOO, nebo LO používáte. Je možné, že to bude chyba nějaké starší verze. Já jsem testoval na AOO 3.4.1, AOO 4.0.1 a LO 4.1.2.3. Testoval jsem také na souboru, který byl vytvořen OOo verze 2.x.x


Pokud je Váš problém vyřešen, označte prosím svůj příspěvek za "VYŘEŠENÝ"
Zlepšíte tak orientaci na fóru při vyhledávání řešení problémů
JAK OZNAČIT TÉMA ZA VYŘEŠENÉ

Offline

Zápatí