Fórum pro uživatele kancelářského balíku OpenOffice | LibreOffice
 

#1 2. 9. 2012 16:07:08

Prefin
Člen
Registrace: 23. 9. 2007
Příspěvků: 7

Při exportu do PDF chybí české znaky

Ahojda všichni.
Mám dokument s vloženými textovými poli, který ve writeru (jako vždy vše) je v pořádku.
Jenže po exportu do PDF mi z těchto text. polí zmizí znaky s českou diakritikou.
Šmíroval jsem kde co udělat ale bez výsledku.
Co je třeba udělat aby se tak nedělo?
Přeci si kvůli tomu nebudu instalovat Wokna lol
Moc díky

Offline

#2 2. 9. 2012 16:22:41

neutr
Člen
Registrace: 8. 3. 2007
Příspěvků: 2,525

Re: Při exportu do PDF chybí české znaky

Teda já přesně nevím, protože mám wokna, ale nejde to uložit jako obrázek? Teda to není řešení tak jak by to mělo být. Nevím jestli a jakou volbu máš pro export do PDF.


Pokud je Váš problém vyřešen, označte prosím svůj příspěvek za "VYŘEŠENÝ"
Zlepšíte tak orientaci na fóru při vyhledávání řešení problémů
JAK OZNAČIT TÉMA ZA VYŘEŠENÉ

Offline

#3 2. 9. 2012 17:43:24

poky
Člen
Registrace: 23. 9. 2005
Příspěvků: 69

Re: Při exportu do PDF chybí české znaky

Nemůžeš ten dokument někde vystavit?
Zkusil jsi změnit font - jaký jsi použil v tom dokumentu?
Jakou verzi OpenOffice/LibreOffice používáš?
Máš nainstalované Microsoft fonty (Arial, Times New Roman...)?

Offline

#4 2. 9. 2012 18:17:17

Prefin
Člen
Registrace: 23. 9. 2007
Příspěvků: 7

Re: Při exportu do PDF chybí české znaky

Soubory jsou tady:
http://prefin.cz/sklad/Voucher4.odt
http://prefin.cz/sklad/Voucher4.pdf
Použitá písma jsou Algeriad D, Bahamas a Arial.
Mocrosoft fonty mám instalnutý.
Používám bohužel ještě OO 3.2.0, protože na Ubuntu 10.04 LTS mi libre nejde instalnout (nesplněny závislosti) a nemám čas na to se v tom teď hrabat.

S tímhle problémem jsem se setkával dřív a to u souborů (pdf), které nebyly vytvořeny u mě ale někde jinde. Po vyplnění tedxtových polí v nich zmizely znaky "č,á,ř".

Myslím že to bude asi už na to poslat starou distribuci Linuxu do .....

Díky za pomoc

Offline

#5 2. 9. 2012 18:58:49

poky
Člen
Registrace: 23. 9. 2005
Příspěvků: 69

Re: Při exportu do PDF chybí české znaky

Mám stejné problémy s tímto souborem, otestováno v nejnovější verzi LibreOffice 3.6.1 i ve stabilní verzi distribuce Debian Sqeeze OpenOffice 3.2.1 - je to reportováno jako bug.

Pomohlo mi odškrtnout (zrušit) volbu "Vytvořit pdf formulář" při exportu do pdf.

U verze OpenOffice 3.2.1 se špatně zobrazí spodní okraj písem "poskytovatele služby", ve verzi 3.6.1 je to už v pořádku (s odškrtnutím volby "Vytvořit pdf formulář").
Verzi OpenOffice 3.4.1 jsem nezkoušel.

Offline

#6 2. 9. 2012 19:13:53

sedlacekdan
Moderátor
Místo Nehvizdy
Registrace: 21. 6. 2010
Příspěvků: 617

Re: Při exportu do PDF chybí české znaky

V AOO 3.4.1 na Linux Mint Debian Edition XFCE se export do PDF provede zcela v pořádku. Nejspíše bude problém někde v oblasti fontů, nebo kódování textu (ISO, UTF ...) zkuste pátrat tímto směrem.


;o)


Linux Mint 16 Petra - Apache OpenOffice 4.0.1
Pokud je Váš problém vyřešen, označte prosím svůj příspěvek za "VYŘEŠENÝ"
Zlepšíte tak orientaci na fóru při vyhledávání řešení problémů
JAK OZNAČIT TÉMA ZA VYŘEŠENÉ

Offline

Zápatí